Wireless networking under FreeBSD for Dell Inspiron 600m
I am really impressed with the ease of using FreeBSD. I could get the wireless working on my Dell Insipron 600m within half an hour and now I am writing this blog using the firefox browser on FreeBSD.
The wireless chipset with Dell Inspiron 600m is Intel(R) PRO/Wireless 2100. I had to implement the following steps to get the wireless card working with FreeBSD 6.1.
1) Installed the required drivers and firmware for the card by doing the following
cd /usr/ports/net/ipw-firmware/
make install clean
This installed the required firmware for the card.
kldload if_ipw
This loaded the kernel module containing the driver.
2) Edited my /etc/rc.conf and added the following two lines
ipwcontrol -i ipw0 -f /boot/firmware/ipw.fw
ifconfig_ipw0="ssid MYSSID wepkey WEBKEY weptxkey 1 wepmode on DHCP"
where MYSSID is the SSID of my wireless network and WEBKEY is 104 bit webkey.
After this I simply executed the command
/etc/rc.d/netif stop
followed by
/etc/rc.d/netif start
And I had my wireless card working.
3) In addition I edited my /boot/loader.conf so that the drivers get loaded automatically on a reboot
wlan_wep_load="YES"
if_ipw_load="YES"